Use of $SPECIAL

Post Reply
johnm99
Posts: 1
Joined: Tue Aug 25, 2009 11:15 am

Use of $SPECIAL

Post by johnm99 » Tue Aug 25, 2009 11:29 am

Using 6.00, the behavior of $SPECIAL is not consistent between LOAD and SAVE/RESAVE. With $SPECIAL set to "GB/", LOAD "directory/progname" will correctly locate and load "directory/GB/progname" but $PROG and CTRL-S will show the program name as "GB/directory/progname".
For example LOAD "SAL/STMT" will load "SAL/GB/STMT" but would be resaved as "GB/SAL/STMT".
Does anyone know if this has been corrected to a consistent approach? If so, in what version of KCML?

Thanks

sgnirtswob
Posts: 41
Joined: Tue May 19, 2009 3:34 pm
Location: Cheshire
Contact:

Re: Use of $SPECIAL

Post by sgnirtswob » Tue Apr 19, 2011 9:55 am

Hello John,

As far as im aware this works as expected in kcml 6.20, I used to use it all the time. I am currently working on a kcml 6.00 system, and experience the same problem as you. Very annoying!

One method around this, might be to change the load menu program you use to perform the $SPECIAL look up and load the full path name where appropropriate. But thats a code change to the core system, so might not be possibloe for you.

Kind Regards
Russell Smithers
XKO, Kerridge, ADP DSI, Bowstrings + Air Products

LinkedIn www.linkedin.com/in/russellsmithers
KCML Group http://www.linkedin.com/groups?about=&g ... _ug_grppro
Facebook www.facebook.com/home.php#/group.php?gid=83435884572

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests